Rotax E-Rave

Forum rules
The forums are a place for open discussion of karting topics. Please respect the opinions of others. No name calling, abuse, bashing etc. of any sort will be tolerated and offending posts will be removed and offenders sanctioned at the discretion of the webmaster or the executive. All posted materials, text, etc. become the property of the CKRC and may be displayed or removed at the discretion of the CKRC.
bspek
Posts: 3
Joined: Mon Sep 25, 2017 8:07 am
First Name: brian
Last Name: spek
City/Town: newmarket
CKRC Member ?: No

Rotax E-Rave

Postby bspek » Tue Sep 26, 2017 8:28 am

Hi, hoping someone has seen this before, as your club sounds like Rotax experts... I have successfully upgraded my 09 Rotax with the EVO uogrades, and is a beast up to 15000rpm. I also have a 2010 motor, and cannot get it past 13200. I have the latest update kits and brackets, correct lengths of new solenoid hoses, and the solenoid is mounted with the silver spout facing upwards etc... Here is the problem... the power valve remains open when starting, and only around 9000rpm it starts to close a bit. Taking the power valve off...it is very hard to squeeze closed, and also stays open when motor is off, with the new spring. It is normal to have to press this hard in order to get the bellows closed? Pls send me any suggestions, I rechecked all the instructions again. Thanks. Brian.

Joey Guyon
Posts: 360
Joined: Wed Oct 22, 2008 10:33 am
First Name: Joey
Last Name: Guyon
City/Town: Calgary
CKRC Member ?: Yes

Re: Rotax E-Rave

Postby Joey Guyon » Thu Oct 05, 2017 9:09 am

Hi Brian,

Good description of your issues. I think your power valve may still have the internal spring! If you take it apart there will be a small spring between the housing of the valve and the black "piston".

Please check to make sure that part is removed and report back!

Joey

bspek
Posts: 3
Joined: Mon Sep 25, 2017 8:07 am
First Name: brian
Last Name: spek
City/Town: newmarket
CKRC Member ?: No

Re: Rotax E-Rave

Postby bspek » Fri Oct 06, 2017 9:14 pm

Fixed, thanks! That was it... Motor now revs 14500. Not too many Rotax motors left down here (I moved to the US from Ontario), I am getting an X30 and will sell this pkg if anyone wants another motor. The 15Krpm motor just sold, but have this one sorted out now and can sell, or I'll keep for friends to drive here. Thanks.


Who is online

Users browsing this forum: No registered users and 1 guest